Google Lens
  • Version: 1.0.180517194
  • Requires: Android 4.0+
  • Developer: Google LLC
  • Category: Tools
  • Updated:June 15, 2018


What's New in 1.0.180517194

You need to update the Google app to use Google Lens.
After you update, you may need to wait up to a day for Lens to be ready to use.

Note: Download and save the apk file to your Android Phone's SD card and install it manually onto the Android device.

If there is any problem please let us know. Write your problem in comment box below.